PAT训练-1020. 月饼 (25)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

两点需要注意:
(1)注意库存可能不是整数(测试点2)
(2)可能库存不够( 测试点3)

代码:

//

//  main.cpp

//  test

//

//  Created by XiaoPeng on 17/2/23.

//  Copyright © 2017 XiaoPeng. All rights reserved.

//

#include <iostream>

#include <queue>

#include <iomanip>

#include <math.h>

#include <vector>

#include <string.h>

#include <algorithm>

using namespace std;

int main(int argc, const char * argv[]) {

    int kind;

    cin>>kind;

    int need;

    cin>>need;

    double * give = new double[kind];

    double * value = new double[kind];

    double * single = new double[kind];

    for(int i = 0 ; i < kind;i++)

    {

        cin>>give[i];

    }

    for(int i = 0 ; i < kind;i++)

    {

        cin>>value[i];

    }

    for(int i = 0 ; i < kind;i++)

    {

        single[i] = (double)value[i]/(double)give[i];

    }

    

    for(int i = 0;i < kind;i++)

    {

        for(int j = i;j<kind;j++)

        {

            if(single[i] < single[j])

            {

                double temp1 = give[i];

                double temp2 = value[i];

                double temp3 = single[i];

                give[i] = give[j];

                value[i] = value[j];

                single[i] = single[j];

                give[j] = temp1;

                value[j] = temp2;

                single[j] = temp3;

            }

        }

    }

//    for(int i = 0; i < kind;i++)

//    {

//        cout<<give[i]<< ” “<<value[i]<<endl;

    

//    }

    double sum = 0;

    for(int i = 0;i < kind&& need>0;i++)

    {

        if(give[i] > need)

        {

//            sum += (double)value[i] * (double)need/give[i];

            sum += need*single[i];

            need = 0;

        }

        

        else

        {

            sum += value[i];

            need -= give[i];

        }

    }

    cout<<setprecision(2)<<fixed<<sum;

}

发表评论