科学计数法是科学家用来表示很大或很小的数字的一种方便的方法,其满足正则表达式[+-][1-9]”.”[0-9]+E[+-][0-9]+,即数字的整数部分只有1位,小数部分至少有1位,该数字及其指数部分的正负号即使对正数也必定明确给出。
现以科学计数法的格式给出实数A,请编写程序按普通数字表示法输出A,并保证所有有效位都被保留。
输入格式:
每个输入包含1个测试用例,即一个以科学计数法表示的实数A。该数字的存储长度不超过9999字节,且其指数的绝对值不超过9999。
输出格式:
对每个测试用例,在一行中按普通数字表示法输出A,并保证所有有效位都被保留,包括末尾的0。
输入样例1:
+1.23400E-03
输出样例1:
0.00123400
输入样例2:
-1.2E+10
输出样例2:
-12000000000
代码:
#include <iostream>
#include <queue>
#include <iomanip>
#include <math.h>
#include <vector>
#include <string.h>
#include <algorithm>
using namespace std;
int main(int argc, const char * argv[]) {
queue<char> temp;
char * list = new char[10000];
for(int i = 0 ; i < 10000;i++)
{
list[0]=0;
}
cin>>list;
int s = 0;
for(s = 1;list[s]!=‘E’;s++)
{
temp.push(list[s]);
}
bool j = true;
if(list[s+1]==‘-‘)
j = false;
char e[5]={0,0,0,0,0};
int y = 0;
for(s = s+2;list[s]!=‘\0’;s++)
{
e[y] = list[s];
y++;
}
int count = atoi(e);
if(j)
{
vector<char> final;
char z =list[0];
if(z == ‘-‘)
final.push_back(z);
int i = 1;
char t = temp.front();
temp.pop();
final.push_back(t);
i++;
temp.pop();
while(count>0)
{
if(!temp.empty())
{
z = temp.front();
final.push_back(z);
temp.pop();
count–;
}
else{
final.push_back(‘0’);
count–;
}
}
if(!temp.empty())
{
final.push_back(‘.’);
while (!temp.empty()) {
z =temp.front();
final.push_back(z);
temp.pop();
}
}
for(int x = 0 ; x < final.size();x++)
cout<<final[x];
}
else{
char z =list[0];
if(z == ‘-‘)
cout<<z;
if(count != 0)
{
cout<<“0.”;
for(int i = 1;i<count;i++)
{
cout<<“0”;
}
while (!temp.empty()) {
if(temp.front()!=‘.’)
cout<<temp.front();
temp.pop();
}
}else
{
while (!temp.empty()) {
cout<<temp.front();
temp.pop();
}
}
}
}