旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。
输入格式:
输入在2行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过80个字符的串,由字母A-Z(包括大、小写)、数字0-9、以及下划线“_”(代表空格)组成。题目保证2个字符串均非空。
输出格式:
按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有1个坏键。
输入样例:
7_This_is_a_test _hs_s_a_es
输出样例:
7TI
代码:
//
// main.cpp
#include <iostream>
#include <queue>
#include <iomanip>
#include <math.h>
#include <vector>
#include <string>
#include <algorithm>
#include <map>
using namespace std;
int main(int argc, const char * argv[]) {
string right;
string simple;
cin>>right;
cin>>simple;
map<char, int> mypool;
for(char temp = ‘A’;temp <= ‘Z’;temp++)
{
mypool[temp] = 0;
}
for(char temp = ‘0’;temp <= ‘9’;temp++)
{
mypool[temp] = 0;
}
mypool[‘_’] = 0;
for(int i = 0,j =0 ; i < right.size();i++)
{
if(right[i]==simple[j])
{
j++;
continue;
}else{
if(right[i]<=‘Z’&&right[i]>=‘A’)
{
if(mypool[right[i]]==0)
{ cout<<right[i];
mypool[right[i]] ++;
}
}
else if(right[i]<=‘z’&&right[i]>=‘a’)
{
if(mypool[right[i] + ‘A’ – ‘a’]==0)
{
cout<<char(right[i] + ‘A’ – ‘a’);
mypool[right[i] + ‘A’ – ‘a’] ++;
}
}
else
{
if(mypool[right[i]]==0)
{
cout<<right[i];
mypool[right[i]]++;
}
}
}
}
}