PAT训练-1018. 锤子剪刀布 (20)

大家应该都会玩“锤子剪刀布”的游戏:两人同时给出手势,胜负规则如图所示:

现给出两人的交锋记录,请统计双方的胜、平、负次数,并且给出双方分别出什么手势的胜算最大。

输入格式:

输入第1行给出正整数N(<=105),即双方交锋的次数。随后N行,每行给出一次交锋的信息,即甲、乙双方同时给出的的手势。C代表“锤子”、J代表“剪刀”、B代表“布”,第1个字母代表甲方,第2个代表乙方,中间有1个空格。

输出格式:

输出第1、2行分别给出甲、乙的胜、平、负次数,数字间以1个空格分隔。第3行给出两个字母,分别代表甲、乙获胜次数最多的手势,中间有1个空格。如果解不唯一,则输出按字母序最小的解。

输入样例:

10
C J
J B
C B
B B
B C
C C
C B
J B
B C
J J

输出样例:

5 3 2
2 3 5
B B

代码:

//
// main.cpp
// test
//
// Created by XiaoPeng on 17/2/23.
// Copyright © 2017年 XiaoPeng. All rights reserved.
//

#include <iostream>
#include <queue>
#include <iomanip>
#include <math.h>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;
typedef struct name{
int B;
int C;
int J;
int win;
int equal;
int lose;
};

int find(char j,char y)
{
switch (j) {
case ‘B’:
switch (y) {
case ‘B’:
return 0;
case ‘C’:
return 1;
case ‘J’:
return -1;
}
break;
case ‘C’:
switch (y) {
case ‘B’:
return -1;
case ‘C’:
return 0;
case ‘J’:
return 1;
}
break;

case ‘J’:
switch (y) {
case ‘B’:
return 1;
case ‘C’:
return -1;
case ‘J’:
return 0;
}
break;

default:
return 0;
break;
}
return 0;
}

int main(int argc, const char * argv[]) {
int count;
name J;
J.B=0;
J.C=0;
J.J=0;
J.equal=0;
J.lose=0;
J.win=0;
name Y;
Y.B=0;
Y.C=0;
Y.J=0;
Y.equal=0;
Y.lose=0;
Y.win=0;

cin>>count;
for(int i = 0; i <count;i++)
{
char j;
cin>>j;
char y;
cin>>y;
switch (find(j,y)) {
case 0:
{
J.equal++;
Y.equal++;
}
break;
case 1:
{
J.win++;
Y.lose++;
switch (j) {
case ‘B’:
J.B++;
break;
case ‘C’:
J.C++;
break;
case ‘J’:
J.J++;
break;

default:
break;
}
break;
}
case -1:
{
Y.win++;
J.lose++;
switch (y) {
case ‘B’:
Y.B++;
break;
case ‘C’:
Y.C++;
break;
case ‘J’:
Y.J++;
break;

default:
break;
}
break;
}
default:
break;
}

}
cout<<J.win<<” “<<J.equal<<” “<<J.lose<<endl;
cout<<Y.win<<” “<<Y.equal<<” “<<Y.lose<<endl;
int max = J.B;
if(max < J.C)
max = J.C;
if(max < J.J)
max = J.J;
if(max == J.B)
cout<<“B “;
else if(max == J.C)
cout<<“C “;
else if(max == J.J)
cout<<“J “;

max = Y.B;
if(max < Y.C)
max = Y.C;
if(max < Y.J)
max = Y.J;
if(max == Y.B)
cout<<“B”;
else if(max == Y.C)
cout<<“C”;
else if(max == Y.J)
cout<<“J”;

}

发表评论